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Installing RoboForm
Here is a video demonstration. (http://www.youtube.com/embed/eki6J83l9E0)

Requirements. RoboForm works on Windows 2000, 2003, XP, Vista, 7, Server systems. Internet Explorer version 6.0 or
later is required. All Service Packs and security patches must be installed.

Start Download. Click the Download RoboForm (http://www.roboform.com/dist/RoboForm-Setup.exe) link and a popup
window will ask if you want to Save or Run the file. Click Run.

Agree to Install RoboForm. Once the download finishes, another popup window will ask "Do you want to run this
software? RoboForm2Go by Siber Systems". Click "Yes" and installation will begin.

Language and License Agreement. Select language in which RoboForm will talk to you. Read the License Agreement and
agree to it.

Setting Up Personal Data. In this dialog you can change folder where RoboForm Passcards and Identities are stored and
where RoboForm should place its program files. You can also request installation of RoboForm Adapter for Mozilla, Firefox
and Netscape.

Close any Internet Explorer and Windows Explorer windows. The RoboForm installer will offer to close all Internet
Explorer and Windows Explorer windows. Click "Yes" and the installer will do it for you. Alternatively you can close these
windows manually. 
If RoboForm keeps asking to close browsers even though you have none left, then click "No" when it asks whether to wait
again and allow installation to proceed; in this case you will have to reboot in order to complete installation.

Create Master Password. Master Password is one password that RoboForm uses to protect all Passcards, Identities and
Safenotes. This is the only password that you actually need to remember.

Tests and Tutorials. After you finished installing RoboForm, you will be offered a test/tutorial page on which you can learn
how to automatically save and fill passwords using RoboForm.

Install, Uninstall, AutoUpdate FAQ. 
More on install, uninstall, version upgrade, AutoUpdate (http://www.roboform.com/support/faq#install).

http://www.youtube.com/embed/eki6J83l9E0
http://www.roboform.com/dist/RoboForm-Setup.exe
http://www.roboform.com/support/faq#install
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RoboForm Files
RoboForm works with these file types:

Login or Passcard. RoboForm saves online passwords into what we call a Passcard. Once the password is saved, RoboForm
will offer to fill it when you visit the login page again.

Bookmark. Same as Netscape bookmark or Internet Explorer Favorite. Has a long text note to be used for site notes.
Bookmarks are shown together with Passcards, as they are a variation of Passcards.

Identity. RoboForm can fill long non-password forms (such as registration or checkout form) from your personal profile that
we call an Identity. You fill in your Identity once with all your personal data and then RoboForm will enter this data into web
page forms for you.

Contact. RoboForm can also be used as an Address Book. Each entry in this Address Book is called a Contact. Contact is an
Identity with fewer fields that is not used in form filling, instead it is used to lookup other people personal data. Contacts are
shown together with Identities, as Contact is just a small Identity.

Safenote. You can store often used secret and non-secret text fragment in what we call a Safenote. Safenote provides safe
storage for important passwords that are not automatically stored in Passcards and for other sensitive or often used
information such as ATM passwords and lock key combinations.

Folder. A ll of the above file can be categorized using Folders -- same as Windows Files Folders. You can build a tree-like
structure using folders and stuff it with your Passcards, Bookmarks, Identities, Contacts and Safenotes.

RoboForm Controls
RoboForm adds Toolbar and other controls to your browser.

RoboForm Upper Toolbar

1. Upper Toolbar. Appears above the web page. To show or hide it, click RoboForm button on standard IE toolbar. You
may have to click it several times to make Toolbar appear. Or select View -> Toolbars -> RoboForm in IE. The toolbar
controls only the browser window in which it appears. 
RoboForm toolbar is not visible. Why? (http://www.roboform.com/support/faq#toolbar) 
How can I customize the RoboForm toolbar? (http://www.roboform.com/support/faq#faq_toolbar_customize)

RoboForm Lower Toolbar

2. Lower Toolbar. Appears below the web page, follows web page both in position and size. Used in browser windows that
cannot have Upper Toolbar -- popup windows in IE, browsers without toolbars (AOL, MSN). Has the same functionality as
Upper Toolbar and looks the same. To show it, right-click web page that has no Upper Toolbar and select "RoboForm
Toolbar", or click RoboForm Taskbar Icon and select "Show Toolbar". The Lower Toolbar controls only the browser window
under which it appears.

3. How to Show / Hide Toolbars. Click the Green Robot icon on Standard IE Toolbar to show/hide
RoboForm toolbar: 
* If no toolbar is visible, then Upper toolbar is shown. 
   If Upper toolbar cannot be shown then Lower toolbar is shown. 
* If Upper or Lower toolbar is visible then it is hidden.

You can also right-click web page and select "RoboForm Toolbar" menu item to show/hide the toolbar.
For web pages that cannot be right-clicked, click RoboForm taskbar icon and select "Show Toolbar".

4. Taskbar Icon. Appears in Taskbar (SysTray). It is used: 
* To make RoboForm work in non-IE browsers that are based on IE (AOL, MSN, etc). 
* To gain easy access to Passcard/Safenote/Identity list and to RoboForm functions. 
* RoboForm2Go: It must be present for RoboForm2Go to work. 
RF Taskbar icon is not visible in the Windows XP Taskbar. What should I do?
(http://www.roboform.com/support/faq#faq_taskbaricon_notvisible)

5. Web Page Context Menu. Appear on web page when you right-click it. Use it when you
need to call RoboForm from a web page that has no RF toolbar. 
It is present only in installed RoboForm, not in Roboform2Go. 

http://www.roboform.com/support/faq#toolbar
http://www.roboform.com/support/faq#faq_toolbar_customize
http://www.roboform.com/support/faq#faq_taskbaricon_notvisible


Web Page Context Menu

AutoSave Dialog

How do I customize (get rid of) RoboForm context menu items?
(http://www.roboform.com/support/faq#faq_customctxmenu)

Passcards (Logins)
Use Passcards to store form data that is specific to the web site that you visit, data such as User IDs, Passwords, Magazine
Survey fields, etc. You can save any form data to Passcards and use it to robo-fill a form later.

Saving Form Data to Passcards

1. AutoSave Login Form Data to Passcard. 
When you manually enter login data to login page and click the Login (Submit) button RoboForm will offer to save this login
info to a Passcard by displaying the AutoSave dialog.

Enter the new Passcard name into the dialog and click Save. If you have other Passcards
already saved for this web site, their names will be shown in the list area below the Passcard
Name. You can select one of these names and it will automatically appear in the Passcard
Name field. If you try to save to the existing Passcard, you will be warned.

2. Forcing AutoSave. 
AutoSave dialog pops up only if: 
- filled form has a password field AND 
form data that you are saving is different from form data that you have in existing Passcards
for this domain. 
You can make AutoSave popup even if these conditions do not hold by: 
- Holding ALT key (Alt+Shift for Firefox) and mouse-clicking the Login/Submit button on web
page, OR by 
- Holding SHIFT key and pressing the ENTER key in the password field (actually, any field
where ENTER causes form submission).

Use Forced AutoSave to: 
- Save login info from pages that have no passwords fields. 
- Resave login data when login web page has changed and RoboForm misses fields or Login button but AutoSave does not
come up automatically because login data is saved already. 
- Save non-login forms for which you will need automatic submission by Login or Fill&Submit.

3. Manual Save to Passcard. 
Click the Save button on the RoboForm toolbar. The Save Forms dialog will come up. Enter the Passcard name and click OK.
All form data from all forms on the web page will be saved to this Passcard. You can also invoke the "Save Forms" command
by right-clicking the web page and selecting Save Forms.

Note that Passcards saved in this way do not retain information about button that you clicked to submit the form (because you
did not click any submit button). So if you try to Login or Fill&Submit such Passcard, RoboForm will find the button it thinks is
the best Submit button -- which may be different from the button you wanted to be clicked. Use Forced AutoSave to tell
RoboForm which button to click.

4. Ignoring Fields in AutoSave and Login: Turing Fields. 
Some sites require you to fill a field that changes on every login. The purpose of the field is to test your intelligence and to
make sure that you are not a robot (or that as a robot you are smart enough to pass Turing test).

This is what we want RoboForm to do for Turing fields: 
- Login command should execute as GoFill, so that you can fill the Turing field. 
- Turing field should not be auto-filled in Login or GoFill, user will fill it per site instructions. 
- Turing field should not be AutoSaved, as it changes on every login.

This is how to mark a field as a Turing field using Passcard Editor. 
- Let RoboForm AutoSave passcard with all fields in it, including the Turing field. 
- Open this newly saved Passcard in Passcard Editor, 
- Click a field that is a Turing field, 
- Select "Edit -> Ignore Field". 
Editor will put "$AnyValueHere$" into the field, 
such fields will be ignored by AutoFill, Login and AutoSave.

More Info 
How can I disable AutoSave just for one web site? (http://www.roboform.com/support/faq#faq_autosave_block) 
How can I permanently disable AutoSave for all web sites? (http://www.roboform.com/support/faq#faq_autosave_off) 
The AutoSave dialog does not come up when I expect it to. Why? (http://www.roboform.com/support/faq#autosave)

Filling Form Data from Passcards

http://www.roboform.com/support/faq#faq_customctxmenu
http://www.roboform.com/support/faq#faq_autosave_block
http://www.roboform.com/support/faq#faq_autosave_off
http://www.roboform.com/support/faq#autosave
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and Mini-Dialog

Filling Form Data from Passcards

1. Matching Passcards button on RoboForm Toolbar 
When you visit a web site for which you saved Passcard(s), the RoboForm Toolbar button that
initially says "(passcards)" will show the name of the Passcard that matches this page. This button
is called Matching Passcards button. Click this button when Passcard name is shown and forms
on the page will be filled from this Passcard.

2. Matching Passcards Mini-Dialog. 
If you have more than one Passcard that matches web site, then ( +N ) will be shown next to the
name of the main matching Passcard, where N is the number of additional matching Passcards.
Mouse over the Matching Passcards button and RoboForm will show mini-dialog that lists all Passcards that match this site.
Select one of them and click Fill Forms button to fill forms from the selected Passcard.

3. Fill & Submit. 
Mouse over the Matching Passcards button and Matching Passcards mini-dialog will appear. If you click Fill & Submit button in
this dialog, RoboForm will fill the form and then automatically submit it.

You can make "Fill & Submit" a default button (initially Fill Forms is the default button) by going to "RoboForm -> Options ->
Toolbar" and checking "Fill & Submit is the Default button for Matching Passcards" option.

4. Edit Passcard and Other Commands. 
If you want to view/edit one of the matching Passcards, mouse over the Matching Passcards button, select the Passcard, click
"..." and then select "Edit". The selected Passcard will be shown in Passcard Editor. 
Once you click "...", you will see many other commands that can be applied to a Passcard: 
- Add Shortcut to Passcard to: Desktop, Links, Quick Launch. 
- Rename, Clone, Delete Passcard. 
- Login, GoFill, GoTo: navigate, fill and possible Submit from this Passcard. 
- Protected/Unprotected: Change Passcards protection status.

5. Passcard Order. 
If you have more than one Matching Passcard for a web site, then RoboForm orders Matching Passcards by how well
Passcard URL matches web page URL: 
- Passcards whose URL exactly matches web page URL will appear on top, 
- Passcards with partial URL match will appear next, the longer the match, the higher the position, 
- Passcards for which server part of URL exactly matches server part of web page will appear next, 
- Passcards for which only domain matches will appear the last. 
- Domain should match with all suffixes included, that is, www.google.com matches mail.google.com but they both do not
match www.google.ca.

Passcards with exact URL match are shown as bold in Matching Passcards mini-dialog.

5a. Default Passcard. 
If two or more Passcards provide the same quality match then you can give a preference to one of them by making it a
Default Passcard. To make Passcard a Default Passcard, mouse over Matching Passcards button, select this Passcard, then
select "... -> Set as Default".

Default Passcard name is underlined in Matching Passcards mini-dialog.

Before version 6.5 RoboForm simply showed the Default Passcard as the top Matching Passcard and it did not do any special
ordering for the remaining Passcards. To get to the old way, uncheck option "RoboForm -> Options -> General -> Show
Matching Passcards with the best URL match on top".

6. Selective Form Filling. 
If you want to fill only some fields on the web page (not all of them), then select (highlight) the part of the web page that you
want to be filled "Fill Forms". RoboForm will fill only the fields that you have selected.

7. Fill Empty Fields Only. 
If you set the Fill Empty fields checkbox in the mini-dialog that comes up when you mouse over Matching Passcards button,
then only the fields that are not filled (empty) will be filled. If this option is unchecked, then RoboForm fills both empty and
non-empty fields.

8. AutoFill Dialog. 
Another way to automatically fill and submit login data from Passcards is to use AutoFill Dialog, described elsewhere in the
manual.

9. Fill Forms by Drag-and-Drop. 
If the "Fill Forms" button does not fill forms from the Passcard, you can drag-and-drop field values from the Passcard Editor
to an online form: 
- Start dragging the field by its drag and drop handle which is a picture of small suitcase, 



Toolbar Logins Menu

- Select the field value or its part and then start dragging the selection. 
- Not all applications will accept a drop part of drag-and-drop.

10. Fill Forms by Copy-and-Paste. 
You can also Copy-and-Paste values into the online form or an application: 
- In Passcard Editor click the Handle icon, it will copy field value to Clipboard. 
- In your online form or application place mouse to field to be filled and press CTRL+V or invoke Paste command using this
application user interface. 
- Most applications can Paste from clipboard. So if Drag-and-Drop does not work, use Copy and Paste.

One-Click Login and Navigation

1. Login. 
Click the Login button on RoboForm toolbar and select a Passcard.
RoboForm will perform the entire login sequence for you: 
(i) Navigate your browser to the login page, 
(ii) Fill the login info from Passcard, 
(iii) Click the Submit/Login button.

Another way to login into Passcard is to click RoboForm Taskbar Icon,
select Logins and then select a Passcard to login to. The picture on the
right shows user selecting Passcard from the list.

Yet another way to login to Passcard is show Passcard in Passcard Editor
and then click the Login button in the Editor.

2. More commands: New Window Login, Go&Fill, GoTo, Fill, Edit,
etc 
- Click the Logins button in RoboForm toolbar, 
- move mouse cursor to a Passcard of your choice, 
- right-click it.

You will see a list of commands that applies to the clicked Passcard: 
- Login in New Window command logs you in in the new browser window. 
- Go&Fill commands performs the first two actions from the login sequence: navigate and fill. 
- GoTo command performs only the navigation action for Passcard. 
- Fill Forms command fills forms from the selected Passcard. 
- Edit command shows the selected Passcard in Passcard Editor. 
- E-Mail command sends Passcard as e-mail attachment using your default mail client. 
- Add Shortcut To command adds shortcut pointing to this Passcard to Desktop, Links toolbar of IE, or Quick Launch are on
desktop. Clicking such shortcut causes Login to Passcard. 
- Rename, Clone, Delete commands rename, clone or delete the selected Passcard. 
- Protected/Unprotected commands change protection status of the Passcard.

3. Recently Used Passcards. 
Recently used Passcards are shown under "(Recently Used Passcards)" in the Logins menu. 
The most recently used Passcard is shown first under (Recently Used Passcards) heading, 
it is also underlined in the main list of Passcards in the menu. 
(Clear List) command clears up the Recently Used Passcards list.

4. Multi-column and multi-page menu. 
If your Passcard list does not fit one column, it will be shown in many columns. 
If your Passcard columns do not fit on one screen, multi-page menu will be shown with Next Page and Prev Page items that
allow navigation between pages.

5. Login Browser options. 
In "RoboForm -> Options -> Login Browser" you can set options that tell RoboForm how to do Login: in the same window or
new window and in what browser.

* Login from Toolbar opens web site in: Same/New Window 
- Same Window (default): When you select a Passcard from Logins menu of RoboForm toolbar, login will be done in the
browser window where Passcard was selected. 
- New Window: Login will be done in new browser window, browser will the same kind as the one where you selected
Passcard.

* Login from Taskbar or Editor opens web site in: Topmost/New Window 
- Topmost Window: When you select Passcard from Logins menu of RoboForm Taskbar Icon or click Login button in Passcard
Editor, login will be done in the topmost browser window, that is, the most recently used browser window. 
- New Window (default): New browser window will be opened.



* RoboForm New Browser Window is. 
When the above option decides to open login in a new browser window, this option tells RoboForm which browser to use. 
- Default Browser (default): Call default browser. 
- Internet Explorer: Call Internet Explorer, even if it is not a default browser. 
- Firefox: Call Firefox, even if it is not a default browser. 
- Other: Open new instance of the browser identified by its EXE file. This EXE file is started with URL as an argument.

* Popup Blocker option. 
If you use an aggressive popup blocker, it will try to block RoboForm from opening a new browser window, because new
browser window is a popup in the simplistic mind of a popup blocker. 
Check the "Popup Blocker is active" option (On by default) and RoboForm will call Default Browser when it needs to open
window. This does not guarantee that new window will be opened, navigation can happen in the same window. But it does
guarantee that there will be navigation at all, which is better than nothing. 
Note that Internet Explorer's own popup blocker (that appeared in SP2) does not have this problem, so if you use IE popup
blocker, there is no need to turn on this option. There we recommend to use IE popup blocker and uninstall all other popup
blockers.

* Default Action for RFP File (Passcard) is Login. 
If checked then default action for Passcard file is Login. 
If not checked (default) then the default action for Passcard is Edit.

6. Multi-Step Logins. 
Some sites such as Bank of America with SiteKey require multi-step multi-page login sequences. While currently RoboForm
cannot run the entire sequence in one click, it can do it in two clicks.

Saving Login into Passcards. 
AutoSave passcards for on each Submit of the login sequence: 
* On the 1st login page: fill out UserID and Alt+Click the Submit button (Alt+Shift+Click for Firefox). This page has no
password field, so simply clicking the Submit button will not cause RoboForm to AutoSave, but clicking Submit button while
holding ALT key will force AutoSave of passcard for this step. 
* On the 2nd login page: fill out the password and click or Alt+Click (Alt+Shift+Click for Firefox) the Submit button. This will
result in AutoSaving the 2nd passcard. Names of the 1st and 2nd passcard must be different, so that they do not overwrite
each other. 
* Passcard names should be descriptive yet short, so that you can easily recognize them. For example, I usually name Bank of
America passcards BOFA-JS-1 and BOFA-JS-2 where BOFA is the site name, JS is the initials of account holder (John Smith in
this case), and 1 or 2 or even 3 is the number of the passcard in sequence.

Logging in using Saved Passcards. 
* Select the 1st passcard from Logins menu (in our example this is passcard BOFA-JS-1), this causes going to the 1st login
page, filling forms and submitting, 
* 2nd passcard name will appear on top of Matching Passcards button in RoboForm toolbar when you come to 2nd login page
(BOFA-JS-2 in our example). 
* Mouse over this passcard and click Fill&Submit. This causes filling of login info from the 2nd passcard and auto-submitting,
which concludes the login sequence. 
* Make sure that the right passcard (2nd and not 1st) comes up in Matching Passcards button when you get to the 2nd page.
On sites that have the same URL for all pages or random URLs RoboForm will not be able to match passcard to the specific
page.

7. Turing Passcards Login. 
Some sites require entering some fields manually, to verify that you are a human or a decently intelligent robot. Such Logins
are called Turing logins and passcards for them are called Turing passcards. Most popular examples of Turing logins are: 
- Entering random number offered as a picture by login page. 
- Entering password using virtual keyboard provided by login page.

You can make RoboForm suspend the automated Login sequence and not enter anything into Turing field (letting you enter it)
using the Ignore Field command described earlier in AutoSave. However, you may need a reminder of what to enter.

Use Login Tooltip for providing such reminder. When you select Edit -> Ignore Field or Edit -> Add Login Tip in Passcard
Editor, special field LoginTip$ is added. Contents of this field are shown when RoboForm is logging into Turing passcard. It
would typically say: "Type password 123456 using login page virtual keyboard".

8. New Account Feature. 
New Account is a beta feature that helps user with two routine tasks: 
(a) Bringing password from the page where account is created to the login page. 
(b) Updating password in Passcard when you change it on web site using password change form.

(a) When RoboForm detects a new password creation form (two password fields near each other with the same values), it will
offer to save the new password and all other fields on a form into a passcard. 
This passcard cannot be used to login, as it does not know login page URL, nor does it have fields that are required on login
page. 



Passcard Editor

But it can be used to fill new password and possibly UserID on login page when you get there after logging out from the new
account. Also this passcard can be used to remember exactly what info you entered when creating this new account, as it
saves all fields entered on account creation page.

(b) When RoboForm detects a new password creation form with 3 fields (one old password and two password fields near
each) and old password is contained in one of your passcards for the domain, it will offer to replace old password with the
new password in this passcard. 
If you agree then password in the passcard will be replaced and RoboForm would add note that says from what and into what
the password was changed, such as: 
10/26/2008: password changed from 'xxx' to 'yyy'

New Account feature is enabled by default. 
You can disable it in RoboForm -> Options -> AutoSave -> Enable New Account feature.

Viewing and Managing Passcards

1. Passcard Editor. 
To view the saved form data, use the Passcard Editor. To
call it from the RoboForm toolbar, click the Logins button and
select Edit. To call it from the RoboForm Taskbar Icon, click it
and select Logins -> Edit. To call it directly from desktop,
select Start -> Programs -> AI RoboForm -> Edit
Passcards.

Passcard Editor window is divided into two panes. Left pane
shows the list of Passcards and folders that you have. Right
pane shows contents of Passcard that you clicked in the left
pane.

2. Saving and Closing. 
You can edit any fields in the Passcard. Click "Diskette" icon on
toolbar or select "Passcard -> Save" and changes made to
Passcard will be saved. Click "Save & Close" button and
changes will be saved and Passcard Editor closed. If you want to discard changes that you made, close the editor by clicking
Red X in upper right corner and when RoboForm asks whether to save changes, click No.

3. Passcard Protection by Master Password. 
Protected/Unprotected button indicates and changes Passcard protection status. 
- Protected means that Master Password is required to open this Passcard. 
- Unprotected means that no password is require to view and use this Passcard. 
- You can change the protection status by clicking this button.

Logoff button indicates presence of Master Password in RoboForm system. 
- Enabled state of Logoff button indicates that Master Password is cached in memory. All Passcards protected by this password
become accessible. 
- Disabled state of Logoff indicates that Master Password is not cached in memory (logged-off state). 
- Clicking enabled Logoff button causes uncaching of Master Password from memory.

4. Login/GoFill/Goto to Passcard. 
Click the Login button in Passcard Editor and RoboForm will open a default browser window and log you into this Passcard in
this window. GoFill and Goto commands are also available.

5. Add/Delete a Note to Passcard. 
Click "Add Note" icon (Note with +) icon on Editor toolbar or select Edit -> Add Note in Passcard Editor and Note field will
be added to the Passcard. Put your comments into this field. Click ENTER in the field if you need more lines. The Note field is
not used to fill forms.

To delete note, click "Delete Note" icon (Note with Red X) or select Edit -> Delete Note.

6. Fill from Passcard. 
Select Action -> Fill Forms and RoboForm will fill forms from this Passcard in topmost browser window. This is not
recommended way to fill forms, as often it is hard to tell which browser is on top. Filling from RoboForm toolbar is a better
way.

7. Delete, Rename and
Clone Passcards. 
Click Passcard in the main
window menu and select
Delete, Rename or Clone
command and RoboForm will



Print List of Passcards - Preview (enlarge) (http://www.roboform.com/images/PrintListPasscards-6.png)

Basic Authentication Dialog

perform the selected
operation. In addition to that
you can right-click a Passcard
in the list of Passcards in the
left pane and select Delete,
Rename or Clone command.

8. Print List of Passcards. 
In Passcard Editor select Passcard -> Print List. A dialog appears that previews the printed list of Passcards. You can click
the Print button to print what you see or click Save to save it to an HTML file.

9a. Send Passcard by E-Mail. 
To send Passcard to a friend by email, open it in Passcard Editor and click Envelope icon in Editor toolbar or select Action -
> E-Mail..... 
You can: (1) send Passcard unencrypted, (2) encrypt it by a password that you would tell your friend over the phone or
messenger, or (3) send the Passcard protected by Master Password -- this choice is not recommended as you would have to
tell your friend your Master Password.

9b. Receive Passcard by E-Mail. 
Your friend has to have RoboForm installed. When your friend opens a Passcard received by email, one of two things will
happen depending on your friend's RoboForm settings specified under RoboForm -> Options -> Login Browser. If the
Default action for RFP file (Passcard) is Login option is checked, then when your friend opens the Passcard it will open
the Passcard and attempt to log your friend in using the credentials. If the setting is unchecked, the Passcard will be shown in
the Passcard Editor. 
Since the Passcard opened from the email resides in temporary file storage, your friend will not see it in his or her list of
Passcards. To copy the received Passcard to his or her Passcard folder, your friend should click the Copy Home button in the
Passcard Editor toolbar of the opened Passcard.

10. Viewing Options

View -> Match URL. 
Passcards have two URLs. The Match URL is compared to the URL of the frame when deciding whether Passcard matches the
web page. The Goto URL is used in Login, GoFill and Goto commands. These URLs are the same for single frame web pages,
they may be different in multi-frame pages.

View -> Empty Fields. 
Show empty fields of this Passcard. By default only non-empty fields are shown.

View -> Passwords As Stars. 
Show passwords fields as Stars ****. By default all fields show their actual values.

View -> Always On Top. 
Show Passcard Editor as Always On Top window. Also invoked by "Push Pin" icon.

View -> Toolbar. 
Show/hide toolbar with commands in the Editor.

More Info. 
* Passcard Security and Protection 
* Backup and Restore Passcards and Identities

Basic Authentication

Basic Authentication is an old user authentication mechanism that is used only by a few sites now. It is also used to memorize
Network Disk password in Windows XP.

AutoFill and AutoSave. 
Basic Authentication dialogs cannot be filled or saved from RoboForm toolbar. 
Both AutoFill and AutoSave work for Basic Authentication dialogs but they are controlled by separate
options: 
- "Options -> AutoSave -> Offer to save Logins from web forms" 
   controls AutoSave for HTML forms. 
- "Options -> AutoSave -> Offer to save Logins from Windows dialogs in Browsers (Basic Auth)" 
   controls AutoSave for Basic Authentication. 
- "Options -> AutoFill -> Offer to AutoFill web forms" 
   controls AutoFill for HTML forms. 
- "Options -> AutoFill -> Offer to AutoFill Windows dialogs" 
   controls AutoFill for Basic Authentication.

Manual Fill Forms. 

http://www.roboform.com/images/PrintListPasscards-6.png


Bookmark in Passcard Editor

Safenote Editor

To fill Basic Authentication dialog from a Passcard, click dialog that you want filled and then select Fill Forms from RoboForm
Taskbar menu.

Manual Save Forms. 
To save a Passcard from Basic Authentication dialog, click the BasicAuth dialog that you want saved and then select Save
Forms from RoboForm Taskbar menu.

No Identities. 
Basic Authentication dialogs cannot be filled from Identities, they can only be filled from Passcards.

Bookmarks
Use Bookmarks to store web address (URL) of the web page that you visited and your comments.

1. Save Web Address to Bookmark. 
Click Save button on RoboForm toolbar or right-click web page and select Save Forms. 
Check "Save As Bookmark" checkbox in Save Forms dialog. 
Click Save button and your bookmark is saved. 
The title of the page is saved as a Note and you can change the saved note in Bookmark Editor.

RoboForm automatically checks "Save As Bookmark" checkbox if the web page has no forms on it. Since many web pages now
have forms, do not forget to check "Save As Bookmark" checkbox if you do not need form data saved.

2. View Bookmarks in Passcard Editor. 
To view bookmarks, use the same Passcard Editor that you use
for Passcards. To call it from the RoboForm toolbar, click the
Logins button and select Edit. To call it from the RoboForm
Taskbar Icon, click it and select Logins -> Edit. To call it directly
from desktop, select Start -> Programs -> AI RoboForm ->
Edit Passcards.

The entire text field on the right is text note that you can use to put
your remarks about the site.

3. Go to a Bookmark. 
From Toolbar: Click the Logins button on RoboForm toolbar and
select a Bookmark. RoboForm will navigate your browser to the
address stored in the selected bookmark.

From RoboForm Taskbar icon: Select Logins and then select a Bookmark to go to.

From Passcard Editor: Open bookmark in Passcard Editor and click the Goto button in the Editor toolbar.

4. Delete, Rename and Clone Bookmarks. 
Click Passcard in the Passcard Editor and select Delete, Rename or Clone command and RoboForm will perform the selected
operation on the bookmark shown in the editor. In addition to that you can right-click a bookmark in the list of Passcards in
the left pane and select Delete, Rename or Clone.

5. Print List of Bookmarks. 
In Passcard Editor select Passcard -> Print List. A dialog appears that previews the printed list of Passcards and
Bookmarks. You can click the Print button to print what you see or click Save to save it to an HTML file.

6. E-Mail Bookmark. 
You can send Bookmark to a friend by email. The procedure is the same as for Passcard.

Safenotes
Use Safenotes to store any secret text data (anything that
RoboForm could not save into Passcards): 
* ATM card passwords, 
* Safe lock combinations, 
* Software activation codes, 
* UNIX telnet and rlogin passwords. 
* et cetera.

1. Safenote Editor. 
A ll viewing and editing of Safenotes is done in the Safenote Editor.
To open it, click RoboForm Taskbar icon and select Safenotes ->
Edit. Or click Safenotes button in RoboForm toolbar and select



New Identity Dialog

Edit.

2. Make Safenotes Button Visible. 
To make Safenotes button visible on RoboForm toolbar, right-click RoboForm toolbar and select "Customize Toolbar". Drag
Safenotes button from the left half of the dialog to the right half. Click Close to confirm.

3. Create a New Safenote. 
Select Safenote -> New in Safenote Editor. 
Or select RoboForm -> Safenotes -> New in RoboForm toolbar. 
Or select Safenotes -> New in RoboForm Taskbar icon.

To create new Safenote and populate it with current clipboard contents: 
Select RoboForm -> Safenotes -> Paste to New in RoboForm toolbar. 
Select Safenotes -> Paste to New in RoboForm Taskbar icon.

4. Delete, Rename and Clone Safenote. 
You can Delete, Rename and Clone safenotes by clicking Safenote in the editor and selecting the corresponding command.
You can also invoke Delete command by clicking on the "Cross" button in the editor toolbar.

5. Print List of Safenotes. 
In Safenote Editor select Safenote -> Print List. A dialog appears that previews the printed list of Safenotes. You can click
the Print button to print what you see or click Save to save it to an HTML file.

6a. Send Safenote by E-Mail. 
To send safenote to a friend by email, open it in Safenote Editor and click Envelope icon in Editor toolbar or select Action -
> E-Mail..... 
You can: (1) send safenote unencrypted, (1) encrypt it by a password that you would tell your friend over the phone or
messenger, or (3) send the safenote protected by Master Password. The last choice is not recommended as you would have to
tell your friend your Master Password.

6b. Receive Safenote by E-Mail. 
When your friend receives a safenote in email, she can open it and the safenote will be shown in Safenote Editor. Of course,
your friend has to have RoboForm installed. 
Since safenote opened from email resides temporary files folder of mail program, your friend will not see it in the list of her
safenotes. To copy the received safenote to her safenote folder, your friend should click Copy Home button in Editor toolbar
of the temporary safenote.

Identities
RoboForm can also fill long non-password forms from your personal profile that we call
an Identity. You fill in your Identity once with all your personal data and then RoboForm
will enter this data into web page forms for you. So Identity is a depositary for all your
personal data used in form filling.

Usually you would need one or two Identities: one for registering for free stuff, another
for making real purchases on the web.

Creating, Editing and Managing Identities

1. Create New Identity. 
In the Identity Editor select the Identity -> New command. RoboForm will ask for an
Identity name and the country in which the new Identity resides. Or click Identity name
in the RoboForm toolbar and select New.

When you create a new RoboForm Identity you are asked what Country your Identity
resides in. The Country setting affects presentation format of the Identity Editor and
form filling rules. RoboForm respects the form filling traditions of your country. It knows
the territorial units of your country, format of phone numbers, birth dates, post codes, and so on. It also knows phone
Country Code and long distance prefix.

2. Edit personal form filling data using Identity Editor. 
* To call it from the RoboForm toolbar, click the Identities button and select Edit. 
* To call it from the RoboForm Taskbar Icon, click it and select Identities -> Edit. 
* Or you can select Start -> Programs -> AI RoboForm -> Edit Identities.

Identity data is presented in several tabs. You can switch
between tabs by clicking their headings. Each tab can have
several instances. For example, each instance of Credit
Card tab represents one credit card, so you can have more



Identity Editor

My Identity button and Mini-Dialog

than one credit card in an Identity.

3. Saving and Closing. 
You can edit any fields in the Identity. Click "Diskette" icon
on toolbar or select "Identity -> Save" and changes made
to identity will be saved. Click "Save & Close" button and
changes will be saved and Identity Editor closed. If you
want to discard changes that you made, close the editor
by clicking Red X in upper right corner and when
RoboForm asks whether to save changes, click No.

4. Identity Protection by Master Password. 
Protected/Unprotected button indicates and changes
protection status. 
- Protected means that Master Password is required to
open this identity. 
- Unprotected means that no password is require to view and use this identity. 
- You can change the protection status by clicking this button.

Logoff button indicates presence of Master Password in RoboForm system. 
The meaning of this button is the same as in Passcard Editor.

5. Add/Delete a Note to Identity. 
Click "Add Note" icon (Note with +) icon on Editor toolbar or select Edit -> Add Note in Identity Editor and Note field will
be added to the current tab instance of this Identity. Put information that did not fit standard identity fields into the Note field.
Click ENTER in the Note field if you need more lines. The Note field is not used to fill forms.

To delete note, click "Delete Note" icon (Note with Red X) or select Edit -> Delete Note.

6. Fill from Identity. 
Click Fill button in Identity Editor or select Action -> Fill Forms and RoboForm will fill forms from this Identity in topmost
browser window. This is not recommended way to fill forms, as often it is hard to tell which browser is on top. Filling from
RoboForm toolbar is a better way.

7. Delete, Rename and Clone Identities. 
Click Identity menu item in the Identity Editor and select Delete, Rename or Clone (Copy) command and RoboForm will
perform the selected command. You can also right-click the Identity name in the left pane of the Identity Editor or in
RoboForm toolbar and select one of these commands from the menu that appears.

8. Change Country of Identity. 
Go to "Edit -> Country" menu and select new Country for your Identity. If you cannot find your country in the displayed list of
countries, select Other country. 
Changing Country may cause some fields to lose their values or values may become corrupted, because different countries
have different sets of fields, with different formats.

9. Print List of Identities. 
In the Identity Editor, select Identities -> Print List. A dialog appears that previews the printed list of Identities. You can
click the Print button to print what you see or click Save to save it to an HTML file.

10. E-Mail Identity. 
You can send Identity or Contact to a friend by email. The procedure is the same as for Passcard.

11. Viewing Options

View -> Always On Top. 
Show Identity Editor as Always On Top window. Also invoked by "Push Pin" icon.

View -> Toolbar. 
Show/hide toolbar with commands in the Editor.

Filling Personal Data from Identities

1. Fill Forms from Identity using RoboForm Toolbar. 
Each of your Identities is shown on RoboForm toolbar as a button. We call this button a
My Identity button.

When you see a form that you need to fill, simply click the button with your identity
name on it and forms will be filled from the Identity that you clicked.

If you want to show more than two My Identity button on Toolbar, right-click Toolbar,
select "Toolbar Options" and change "Number of My Identity buttons".



The Identity Editor may remain displayed when you are robo-filling forms. But remember that changes that you make in the
Identity Editor become effective only after you save them.

2. Selecting Tab Instances. 
If you need to select a Credit Card or another tab instance before filling, mouse over the My Identity button and RoboForm
will show mini-dialog that allows you to select Credit Card and other tab instances to be used in form filling. Make your
selection and click Fill Forms button.

3. Fill & Submit. 
Mouse over the My Identities button and form filling mini-dialog will appear. If you click Fill & Submit button in this dialog,
RoboForm will fill the form and then automatically submit it.

You can make "Fill & Submit" a default button (by default Fill Forms is the default button) by going to "RoboForm -> Options
-> Toolbar" and checking "Fill & Submit is the Default button for My Identities" option.

4. Selective Form Filling. 
If you want to fill only some fields on the web page (not all of them), then select (highlight) the part of the web page that you
want to be filled "Fill Forms". RoboForm will fill only the fields that you have selected.

5. Fill Empty Fields Only. 
If you set the Fill Empty fields checkbox in the form filling mini-dialog that comes up when you mouse over My Identity
button, then only the fields that are not filled (are empty) will be filled. If this option is unchecked, then RoboForm fills both
empty and non-empty fields.

6. Selecting Phone Prefix. 
RoboForm knows phone number format and country code for all major countries. When filling forms, it adds Phone Prefix
before the number. Phone Prefix is set in Identity Editor in Person tab. It can be set to one of: 
* None: no prefix (default option for the US), 
* National: prefix that is dialed to call long distance inside the country (1 in the US, 0 in most Euro countries). 
* Country Code: country code, used when dialing from foreign countries.

7. English Selection Values Option. 
This option is located on the form filing mini-dialog that appears when you mouse over the Identity in RoboForm toolbar. If
this option is On then English values are used when filling out fields that are presented as selections in Identity and as plain
text fields in online form. If this option is Off then the value in the language local to your current identity is used.

8. AutoFill Dialog. 
Another way to automatically fill and submit personal data from Identities is to use AutoFill Dialog, described elsewhere in the
manual.

9. Drag-And-Drop Identity Fields to Online Form. 
If Identity does not fill some fields automatically, you can drag-and-drop field values from the Identity Editor to the online
form. There are two ways to pick up a field in Identity Editor: 
- Start dragging the field by its drag-and-drop handle (which is a small picture of a suitcase), 
- Select field value or its part and then start dragging the selection.

10. Copy-and-Paste Identity Fields to Forms and Applications. 
You can also Copy-and-Paste values into the online form or an application (most applications can Paste from clipboard): 
- In Identity Editor click the Handle icon, it will copy field value to Clipboard. 
- In your online form or application click the field to be filled and press CTRL+V or invoke Paste command using this
application user interface. 
- You can copy and paste field combinations and entire tabs. The handle for a tab is at the upper left corner of the tab.

More Info. 
* Identity Security and Protection 
* Multiple Credit Cards and Addresses 
* Frequently Asked Questions about Form Filling from Identities (http://www.roboform.com/support/faq#formfill)

Identity Tabs and Tab Instances

Fields in the Identity are grouped in tabs. You can see
only one tab at a time in Identity Editor. When you
click on another tab, you will see another group of
fields.

These are tabs available in Identity: 
- Person 
- Business 
- Address 

http://www.roboform.com/support/faq#formfill


Credit Card Tab Instances in Identity Editor

- Credit Card 
- Bank Account 
- Authentication.

Each tab can have many instances. Example: Credit
Card is a tab in Identity. Credit Card tab can have
many instances. So you can store many credit cards in
one Identity. Each tab instance has a name.

There are two additional tabs in Identity that cannot have instances: 
- Summary. This is just a non-editable summary of all other tabs. 
- Custom. This contains user-defined fields.

Instance Tree in Left Navigator. 
The whole tab and tab instance hierarchy is shown as a tree in the left navigator window: 
- If tab has only one instance, it is shown as a tree node directly under the identity node. 
- If tab has more than one instance, then the tree node under the identity represents the tab itself (one level down) and
children nodes of the tab represent individual tab instances (two levels down).

When tab has only one instance, the name of this instance is not shown, instead tab name (such as Credit Card or Person) is
shown. When you create second instance of the tab, then the first instance of the tab gets the default name "[Main]". You can
change the default instance name by renaming the instance.

Create New Instance. 
Select tab in which you want to create new instance by clicking it in the list of tabs. 
A button with current tab name in Editor Toolbar indicates what tab you selected.

Click "New <Tab Name>" button in Editor toolbar, 
this would create new instance of tab. 
For example, to create second Credit Card, click "Credit Card" tab, then click "New Credit Card" button.

Delete Instance. 
Click tab name in Editor toolbar, select Delete, this would delete the current instance. 
Or right-click the instance in the Left Tree Navigator and select Delete. 
For example, to delete an Address that you do not need, select the Address to delete in Left Navigator Tree, then select
"Address -> Delete" in toolbar or right-click instance in the tree and select Delete.

Rename Instance. 
Select the instance to be renamed in the Left Tree Navigator, right-click it and select Rename. Or click tab name in Editor
toolbar and select Rename. This would rename the selected instance.

Clear Instance. 
Click tab name in Editor toolbar, select Clear. This would empty all values in the current instance.

Form Filling with Instances. 
Mouse over the button that has name of your Identity on it. A list of all instances will be shown and you will be able to select
what instances to use in form filling before clicking Fill Forms button.

Identity Fields and Tab Meaning

Identity is made of tabs. Every tab represents an object in real world. So Identity bundles together a bunch of related real
world objects. All tabs can have multiple instances, each representing an object of the same kind. 
The meaning of most Identity fields is obvious, here are some explanations for those that are not.

* Summary Tab

Summary tab is an informational tab that shows summary of fields in the Identity or Contact. It cannot be edited, you need to
edit the tabs from which this summary data is assembled. Summary tab has only one instance.

* Person Tab

Person is a live person that is identified by his/her name, date of birth, Social Security Number or its equivalent. A person has
a set of phone numbers associated with him/her. Also a person has an email and several instant messenger IDs.

Several persons that form a family usually appear in one Identity. In a business world, several Persons who belong to the
same Business can be put into one Identity.

Title is the same as Salutation.

Phone Numbers. 



* Phone Number format depends on Country of your Identity, so make sure that Country is correct. 
* Do not enter country code and/or dialing prefixes into Phone Numbers. RoboForm generates these prefixes automatically
when filling forms. Example: German phone number "551 53 11 508" should not be entered as "0-551-53 11 508" or "+49-
551-53 11 508", RoboForm can generate both long distance prefix "0" and country code "49" when filling forms. 
* The field after "x" is for Extension. Put it in if your phone number has one. 
* Phone is your default phone, it is filled when web site form asks for Phone without saying which phone it is -- Home or
Work. 
* We assume that your Daytime Phone is same as your Work Phone and your Evening Phone is same as your Home Phone,
that is that you work at daytime and go home in the evening.

Income: put in an integer in dollars, do not use commas, dots or dollar/pound signs.

Driver License Number: do not use dashes or spaces.

* Business Tab

Business Tab represents a business entity such as Company, Corporation, Organization, Government Agency, School or
Church with which Person(s) are associated (they work in there, or visit there).

Business has a name, Web Site, business type, etc. Business address is stored in Address tab.

Business phones are stored in Person tab. If you do not know any specific person in the business, you are filling fields for a
virtual person such as phone operator or sales or support person.

* Address Tab

Address is an address of a physical (geographical) location. You can have several Addresses in an Identity. For example, a
family would have their main home as first Address as their vacation home as second Address. A company would have each
office as an Address.

Address format depends on Country of your Identity, make sure Country is correctly. Country field in Address tab is not
editable, you can change it in Edit -> Country, thus changing the Identity country-related formats and rules.

Address Line 1 contains House Number and Street Name. 
If you use a PO Box, put the PO Box number into this line like so: "PO Box 10101". 
Address Line 2 contains your Apartment Number like so: "Apt. 202". 
Actually you can put whatever you want in both lines. 
Zip 5+4: the last 4 digits of the Zip code are not required. 
Moreover, some sites allow Zip codes only with 5 digits.

* Credit Card Tab

Just a Credit Card. A family or a company can have one or more credit cards.

Credit Card Number: enter it without dashes or spaces. 
Card Validation Code: this is a 3- or 4-digit number that is usually printed next to your signature. This is a new credit card
verification feature that is requested fairly often by sites. 
Card User Name should be in format "FirstName LastName", no Middle Initial is allowed. 
Card Customer Service Phone is the 800 number of Customer Service of your Card Issuing Bank.

* Bank Account Tab

Same as with credit cards, a family or a company can have several bank accounts and RoboForm reflects that.

* Authentication Tab

Here you can store your favorite passwords and security questions that you would use when creating new accounts.

The User ID and Password fields are your *default* passwords. When you want to save an existing UserID/Password pair,
use Passcards for this, do not put them into Identity. Put into Identity the default low-security UserID/Password pair that you
would use for security-insensitive sites. 
Password Question is the question that that sites ask you when you forget the password. Many sites allow you to define this
question, hence the field. A common question is "What is your mother maiden name?" 
Password Answer is your standard answer to the standard question above.

AutoFill Dialog

1. Do You Really Need AutoFill? 
AutoFill was the recommended way to fill forms in RoboForm ver 5 and before. In ver 6 AutoFill is
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not needed for filling/saving HTML forms as it is fully replaced by the toolbar. It is still needed to fill
Basic Authentication forms, though.

Some people like AutoFill dialog because: 
- If one uses AutoFill dialog, he can hide RoboForm toolbar, 
- AutoFill attracts more attention than button on the toolbar.

Some people (including us) do not like AutoFill, because: 
- It takes space when it pops up, so it can hide a part of web page. 
- Sometimes AutoFill appears when you do not want to fill forms, it can get annoying.

2. How Does AutoFill Work. 
By default AutoFill dialog is disabled. To enable AutoFill dialog, 
go into "RoboForm -> Options -> AutoFill" and 
check "Offer to AutoFill Web (HTML) Forms".

AutoFill dialog pops up if you navigated to web page that contains: 
- a password form for which you saved a Passcard from which this form can be filled, OR 
- a long (more than 4 fields) non-password form that RoboForm can fill.

AutoFill dialog shows the list of: 
- Fillable Passcards AND 
- Identities, all of them.

How to Fill: 
- Click the Passcard or Identity you want to fill from and selected Passcard/Identity is highlighted. 
- Click Fill Forms button or press the Enter key and forms will be filled from the selected file. 
- Click the "No" button or press the ESC key if you do not want to fill forms.

3. Fill & Submit. 
If you click Fill & Submit button in this dialog, RoboForm will both fill forms and click the Submit button for you.

If you want to make "Fill & Submit" a default button (initially Fill Forms is the default button) when Passcard is selected, then
go to "RoboForm -> Options -> AutoFill" and check "Fill & Submit is the Default button for Matching Passcards".

If you want to make "Fill & Submit" a default button when Identity is selected, then go to "RoboForm -> Options -> AutoFill"
and check "Fill & Submit is the Default button for My Identities".

4. Fillable Passcards vs Matching Passcards. Fillable Passcards are defined as Passcards that: 
-- Have URL that matches URL of the current web page, AND 
-- Can fill forms on the current web page.

Note that AutoFill lists fewer Passcards than RoboForm Toolbar, because Toolbar matches Passcards only by URL while
AutoFill actually tries to fill forms from Passcards invisible and rejects Passcards from which forms on the page cannot be
filled.

5. Manually calling up AutoFill. 
If AutoFill dialog does not come up, you can call it up: right-click the web page and select Fill Forms. 
Or click RoboForm Taskbar Icon and select Fill Forms and RoboForm will popup AutoFill for the topmost (last seen) web
browser.

6. Temporarily Disable AutoFill. 
If you want to be able to quickly turn off the AutoFill dialog, go into "RoboForm -> Options -> AutoFill" and check "Show
Enable/Disable AutoFill command in main menu" option. 
This will add "Enable/Disable AutoFill" command to RoboForm main menu in Toolbar and Taskbar icon.

7. When AutoFill Pops Up: Fine-Tuning Rules. 
In "RoboForm -> Options -> AutoFill -> When AutoFill Pops Up" you can control popping up of AutoFill: 
* Only from Passcards / Only from Identities 
By default AutoFill pops up when it can fill form from Passcards OR Identities. 
Using this option, you can limit popups to Passcards only or Identities only. 
* Only On Pages with Passwords 
By default AutoFill from Passcards pops up only on pages that have password fields. If you uncheck this option, AutoFill will
popup on pages with no password fields, as long as there are matching Passcards for the page. 
* Number of Fields that Trigger AutoFill from Identity 
By default AutoFill from Identities pops up if there are at least 4 fillable fields on the page. 
You can change minimal number of required fields in this option.

8. Customizing AutoFill Dialog Appearance. 
In "RoboForm -> Options -> AutoFill -> AutoFill Dialog Appearance" you can change AutoFill appearance: 
* AutoFill Dialog Position 
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By default AutoFill dialog appears to the right of the browser window, outside the window (Right Out). You can change it to
Center -- in the center of the browser window, or to Right In -- inside the browser window, to the left of the right border of
the window. 
If there is no enough space on the outside of browser window for AutoFill to appear, it will appear inside the window. 
* AutoFill Steals Keyboard Focus 
By default AutoFill dialog does not change the keyboard focus when it appears. If you check this option, then AutoFill dialog
would steal keyboard focus when it appears. That is, you will be able to use keyboard commands of AutoFill dialog without
clicking it with the mouse first. 
* Hide AutoFill when Browser is not on top 
By default AutoFill dialog remains visible when underlying browser window becomes inactive, that is, when browser window is
not the top window on desktop. If you check this option, RoboForm will hide AutoFill dialog if underlying browser becomes in
active (not topmost).

9. AutoFill Without Asking. 
If you want RoboForm to fill all forms without requesting permission (we do NOT recommend this) then open the Options
dialog, switch to AutoFill tab, make sure that "Offer to AutoFill Web Forms" is checked and then check the AutoFill Without
Asking checkbox. Then instead of showing the AutoFill dialog RoboForm will fill forms from the best fitting Passcard or if no
matching Passcards are available, from the most recently used identity.

More Form Filling Commands
These commands are not related to either Passcards or Identities.

1. Clear Fields. 
"RoboForm -> Fields -> Clear Fields" command clears all fields. It clears all form fields or all selected fields.

2. Reset Fields. 
"RoboForm -> Fields -> Reset Fields" command resets all fields or all selected fields to their default values (values that fields
had when the page finished downloading). If all default field values are empty, it performs the same action as "Clear Fields".

3. Set Fields. 
"RoboForm -> Fields -> Set Fields" command sets all checkbox fields in a form or its selected fragment. This command also
works on fields of other types. It puts the value of a custom field named "Set Fields Value" into all fields in the form or all
selected fields. You can use it to fill several adjacent fields with one value.

4. Putting these Commands on Toolbar. 
Each of these commands has a button for it on RoboForm toolbar. To make this buttons visible, right-click RoboForm toolbar,
select Customize and move these buttons into "Current toolbar buttons".

Search Box
Search Box appears between RoboForm button and Logins button on RoboForm Toolbar.

Start typing a word or sentence and RoboForm will show you where the typed
word/sentence can be searched or what other actions can be applied to it. If you press
ENTER, the first shown choice is executed. Use up-down arrow buttons or mouse to select
another search choice.

Default Action. When you select an item in search box, its default action is executed: 
- For Passcards default action is Login, 
- For Bookmarks it is Goto, 
- For Safenotes and Contacts default action is Edit, 
- For Identities default action is Fill Forms, 
- For Search Engines and SearchCards default action is Search.

Alternative Actions - RightClick. 
Or you can right-click the item in the search box list and 
select an alternative action to be applied to the typed string. 
Example: you can Edit passcard that you found instead of Logging in, or 
you can Login In New Window instead of Login in Same Window.

Find Passcard, Safenote, Identity by Name. 
Search box shows Passcard, Safenote and Identity names that have the typed word as a part of their name. If you typed less
than 3 characters, it shows Passcard, Safenote and Identity Names that begin with the typed sequence.

Search for String in RoboForm File Contents. 
Type a word in Search Box, select "Search 'word' in RoboForm Files" and 
typed "word" will be searched in bodies of all RoboForm files.



Query Search Engine (Yahoo - F3). 
Type a phrase in Search Box, select "Search 'phrase' in Yahoo" or click F3 and 
typed phrase will be searched in Yahoo search engine. 
More search engines are available thru customization.

More Search Engines (Google - F6). 
Enable "Search 'phrase' in Google" or any other search engine in Options -> Search. 
Type a phrase in Search Box, select "Search 'phrase' in Google" or click F6 and 
typed phrase will be searched in Google. 
Any search engines or information lookup can be added using SearchCards, see below.

SearchCards - Ultimate Flexibility in Search. 
Any sequence of: (i) navigating to the web page, (ii) filling forms from passcard, (iii) clicking Submit button, can be
automated using a SearchCard, available at RoboForm ver 6.7.6. 
Word or sentence that you type in Search Box becomes an argument to SearchCard, and when you type a word or sentence in
Search Box, select one of the SearchCards and click ENTER, the whole navigate-fill-submit sequence is executed automatically
for you.

Download SearchCards from SearchCard Place. 
Our staff and outside contributors have created these valuable SearchCards 
that will save you hours of clicking on the Web. 
You can download them for free from SearchCard Place (http://www.roboform.com/searchcardplace.html).

How to Create a SearchCard. 
* Navigate to a web site, say, to maps.google.com (if you want to create a SearchCard for Google Maps). 
* Type word rfarg (for argument) into the search/lookup field. 
* Alt+Click (Alt+Shift+Click for Firefox) the Submit/Search button, in this example "Search Maps" button. 
* AutoSave dialog comes up, with "Save SearchCard" box checked. 
* Type descriptive name into Passcard Name, such as "Google Maps". 
* Click "Save" and your SearchCard is saved. 
* Now when you type "11781 Lee Jackson Memorial Hwy, VA 22033" into Search Box, Google Maps appears as one of Search
Choices. If you select it, RoboForm goes to maps.google.com, enters "11781 Lee Jackson Memorial Hwy, VA 22033" into
search field, and clicks Search Maps button. 
* Since this SearchCard executes 3 steps, it is called a 3-step SearchCard.

1-step SearchCards vs 3-step SearchCards. 
If search argument appears in URL of the web page with results, then it may be possible to navigate to the result page directly
and search arguments embedded into URL will cause web site to perform the search. 
If RoboForm sees that rfarg string that you entered into search field appears in URL of the results page then it will offer to
save 1-step SearchCard that goes to the result URL directly. 
Note that not all SearchCards work in 1-step variant, as often all 3 steps are required. Example: Google Maps SearchCard does
not work as a 1-step SearchCard, it requires 3 steps.

Domain Completion SearchCards. 
When you want to automate adding prefixes and suffixes to domain name, such as www.word.com, www.word.org,
www.word.co.uk, you can do it using 1-step SearchCards. 
Example: you want to create a SearchCard that will navigate to www.word.ac.uk when you type word. Download and save
any other Domain Prefix/Suffix SearchCard, for instance, Go to www.arg.org from SearchCard Place
(http://www.roboform.com/searchcardplace.html). In this passcard change URL from www.%rfarg%.org to
www.%rfarg%.ac.uk and Prompt$ to "Go to www.%rfarg%.ac.uk". Name this searchcard appropriately (say, WwwArgAcUk)
and you are done.

Text Selection as Search Argument. 
Select any text on web page and click RoboForm Search Box and 
the selected text appears in Search Box automatically. 
A ll you have to do is to select search action from the menu. 
Example: select Siber address on the Contact (http://www.roboform.com/support) page and then 
select Google Maps (created per instructions above) from the search list.

Hot Keys. 
Every SearchCard can be assigned a Hot Key, so that 
instead of going up and down the list of Search Choices 
you simply click the Hot Key for this SearchCard. 
Hot Keys are assigned in RoboForm -> Options -> Search.

Search Prompt. 
You can control what is shown in Search Box for your SearchCard. 
Edit the Prompt$ field in the SearchCard using Passcard Editor. 
%rfarg% is replaced with the typed sentence. 

http://www.roboform.com/searchcardplace.html
http://www.roboform.com/searchcardplace.html
http://www.roboform.com/support
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Folders in Passcard Editor

For instance, you may want to have the following Prompt$ in Google Maps SearchCard: 
Show '%rfarg%' in Google Maps

Argument Entry Dialog. 
If you select SearchCard from Logins menu of RoboForm toolbar then SearchCard Argument Entry dialog will be shown, it
requests values of searchcard arguments. 
You can change prompts for arguments using the Prompt field of the searchcard: 
%rfarg:-Enter Address Here% 
that appears in Prompt field of SearchCard sets prompt to "Enter Address Here".

Multiple Arguments. 
You can have more than one argument to a SearchCard. 
In this case arguments should appear in SearchCard as %rfarg1%, %rfarg2%, and so on. 
When you enter more than argument in search box, they should be separated by , (comma).

Folders
You can use RoboForm Folders for the same purpose you use
Windows folders -- to organize and classify your files, in this case
Passcards, identities or Safenotes.

Home Folder and Tree of Folders. 
You start building your tree of folders from the Home Folder. All
your Passcards and identities are initially stored in the Home
Folder and if you never create a sub-folder in Home Folder, you
will have a completely flat set of files.

You can create one or more folders in the Home Folder and put
your RoboForm files into them, this classifying your files.

Creating Passcard (or any File) in a Folder. 
When creating a new Passcard in SaveForms dialog (or new Identity
in New Identity dialog or Safenote in New Safenote dialog), click
"Create In" button in the dialog and RoboForm will show you the previously hidden right half of the dialog that allows you to
select the folder into which the newly created file will placed.

Creating New Folder. 
When creating a new file (such as in Save Forms dialog), select the existing folder and click the New Folder button. New folder
will be created in the selected folder after you enter new folder name. Initially you only have Home Folder, so your first new
Folder will be created in Home Folder.

Folders in Logins. 
Folders will be shown in Logins (Identities, Safenotes) menus
in RoboForm Toolbar and Taskbar. The tree of folders is
shown as cascading menu and can drill down into the folder
just by mousing over it.

Folders in Editors. 
Open Passcard, Identity or Safenote Editor and you will see
the tree of folders that you created in the left Navigator
window. If you click the "+" on the folder, the folder will open
to show its contents. If you click the folder itself, the files
contained in it will be shown on the right.

You can do a number of file/folder operations using Editors.

Copy File from Folder to Folder. 
Go to the source folder, right-click the file to be copied in the
left navigator pane and select Copy or press CTRL+C. Then
right-click the destination folder and select Paste or press CTRL+V. File will be copied.

Move File from Folder to Folder. 
Go to the source folder, right-click the file to be moved in the left navigator pane and select Cut or press CTRL+X. Then right-
click the destination folder and select Paste or press CTRL+V. File will be moved.

Delete Folder. 
Right-click folder and select Delete.



Password Generator

Request Master Password

Password Generator
The Password Generator generates random passwords of any length. Randomness of
generated passwords makes them hard to guess.

Starting Password Generator: 
- Mouse over the Generate button in RoboForm toolbar; OR 
- Click RoboForm button in toolbar or RoboForm Taskbar Icon and select "Tools ->
Generate Passwords".

Generating Passwords. 
- When the Generator window comes up for the first time, it automatically generates new
password. 
- To generate another password, click Generate button.

Filling Generated Passwords into HTML forms. 
- Click Fill to fill the generated password into password fields. 
- If you want to fill only some password fields, select them before clicking Fill button
(grab text before and after the fields too).

Using Generated Passwords in Other Applications. 
- Click Copy button to copy generated password to clipboard. You can then paste it into any text/password field in any
application. 
- Drag generated password into any text field that accepts drag-and-drop.

Customizing Generated Passwords. 
- Number of characters in the password, character set and other settings can be changed in the dialog itself. 
- RoboForm shows bit strength of the generated password. We recommend to have at least 64 bits there.

Using Password Generator to Change Password in Online Account. 
How to change your password in online account to a password generated by Password Generator: 
- Login into your account and go to Change Password section. 
- Mouse over Generate button and click Generate to get a new password. 
- Click Generate -> Fill to fill the generated password into online form. 
- If you have several password fields on the form (old and new password), select fields to be filled. 
- Click Submit button to make the change on the site. 
- Log out from the account. 
- Go back to login page using GoFill on the old passcard. 
- Fill the newly generated password using the Generate -> Fill button. 
- Click the Login button. 
- AutoSave offers to save newly generated password off the official login page.

Password-Protecting Files by Master Password
If other people have access to your computer and you do not want them to view
or use your Passcards, Identities or Safenotes (files), then you should protect
these files with Master Password. We describe password protection as applied to
Passcards for brevity. All commands and displays are the same for Identities and
Safenotes.

1. Password Protection by Master Password. 
Passcard (or any file) is said to be Password-Protected by Master Password if
in order to open and use or edit a passcard you are required to enter Master
Password, as in picture on the right.

2. View and Change the Password-Protection Status of
Identity and Passcard. 
To check whether a Passcard (Identity) is password-protected, display
it in the Passcard (Identity) Editor: 
* If editor toolbar displays Unprotected button with Blue Lock icon
then this Passcard is un-protected. Click this button to change
protection status to password-protected. 
* If editor toolbar displays Protected button with Yellow Lock icon
then this passcard is password-protected. Click this button to change
protection status to not-protected.

3. Password-Protecting New Files. 
You are asked to create new Master Password when you install



Protected Passcard in Editor

Set Master Password Dialog

RoboForm for the first time. New RoboForm files are automatically
protected when they are created, if Master Password has been setup
and Password-Protect NewPasscard/ Identity/ Safenote option is set in RoboForm -> Options -> Security. We strongly
recommend password-protecting files that contain sensitive data such as user IDs, passwords, credit card numbers and
social security number.

4. Master Password Caching. 
Once you enter the Master Password, it is cached in memory, so that you do not need to reenter it over and over again. Master
Password remains cached as long as RoboForm remains in memory.

When Master Password is cached in memory, RoboForm Taskbar icon and RoboForm Toolbar icon will turn into a stylized
Robot with sunglasses. When no passwords are cached, the icon is simply Robot without sunglasses.

5. Logoff. 
You can force RoboForm to purge cached Master Password from memory by selecting the RoboForm -> Logoff menu item
on the toolbar or by clicking the Logoff button in the Editor.

RoboForm automatically logs you off (purges cached Master Password from memory) after 120 mins (2 hours) of inactivity.
You can change this setting in the "RoboForm -> Options -> Security" dialog.

RoboForm Taskbar icon must be present for Auto-Logoff to work. Taskbar icon is the agent that auto-clicks the "Logoff"
button for you.

6. Change Master Password. 
If you decide to change your Master Password, you can do so by opening the
Options dialog (select "RoboForm -> Options" in the toolbar) and clicking "Set
Master Password" in the "Security" tab.

The "Set Master Password" command will change the password in every
passcard and identity, so that you do not have to do it manually. It also has a
radio button option to password-protect or password-unprotect all Passcards
and Identities.

Master Password may consist of any characters. It cannot start and end with
spaces. The length of Master Password can be anywhere from 4 to 49
characters. We recommend to make your Master Password at least 8
characters long. It must not be any word or name from the dictionary, so that
it cannot be easily guessed using dictionary attack.

7. Dual Master Password (ver 6.4.0 and up). 
Dual Master Password allows you to give different levels of access to a
passcard, depending on which variant of Master Password is entered. Dual Master Passwords consists of two parts separated
by backslash "\".

* If only the first part of the password is entered (Example: employee enters "pass") then user can only Login to passcard but
not view or edit passcard. 
* If both parts of the Master Password are entered (Example: supervisor enters "pass\word") then user gains unlimited access
to passcard which includes viewing and editing. 
* Note that the "long" Master Password (both parts) should contain at least 4 characters.

Dual Password mode is available only in AES, BlowFish and RC6 encryption methods. To enable it, go to "RoboForm ->
Options -> Security" and check "Dual Password" checkbox. Passcards saved when Dual Password mode is On will have the
special interpretation of backslash inside the Master Password, as described above.

How to migrate to Dual Password system: 
* In RoboForm -> Options -> Security select AES, Blowfish or RC6 encryption algorithm. 
* Check Dual Password checkbox in the same tab. 
* Click "Set Master Password" button. Enter old master password and new master password in the form "pass\word". This will
re-protect your passcards with the new master password.

8. Master Password and Other Passwords. 
Each Passcard (or any RoboForm file) is password-protected by its own password and this password is used as a key to
encrypt and decrypt the passcard.

To reduce the number of passwords that you need to remember to just one, RoboForm forces you to use the same password
for all RoboForm files.

However, if you changed the Master Password in the past, or if you have imported Passcards from another computer then you
might have Passcards protected by different master passwords.

RoboForm caches two most recently entered password in memory.



9. Encryption Strength 

These are encryption key lengths for different encryption methods.

Algorithm Key Length Block Size

AES 128-256 16

Blowfish 256 8

RC6 256 16

3-DES 64 8

1-DES 64 8

   

AES key length depends on Master Password key length: 
* 128 bit for MP less than 32 chars, 
* 192 bit for MP from 32 to 47 chars, 
* 256 bit for MP 48 chars or longer.

More Info. 
* Frequently Asked Questions about Password Protection (http://www.roboform.com/support/faq#security)

Personal Data Security in RoboForm

The security of sensitive digital assets such as Identities and Passcards has several aspects: 
1. Can the legitimate user change her confidential info and/or delete it from computer with no trace left? 
2. Is backup and restore of confidential data available? Is it easy? 
3. Can an unauthorized user who has obtained access to your computer (physically or via Internet) use your confidential data?

Here we compare approaches of other password management services to the RoboForm approach:

Internet Explorer AutoComplete. 
1. It is not completely clear where IE keeps passwords memorized by AutoComplete. It is even less clear whether this
information can be removed without a trace left. 
2. Password info cannot be backed up and restored. 
3. Anybody who has physical access to your computer can make IE "remember" your passwords by finding your sensitive sites
in Favorites and History, visiting them and clicking Arrow Down key in the password fields.

RoboForm. 
1. RoboForm stores your personal info in a known place on your computer and nowhere else. Once you delete RoboForm
User Data Folder, all your confidential data is gone with no trace left. 
2. You can backup and restore RoboForm User Data Folder easily. 
3. If you password-protect your Passcards and Identities, nobody will be able to read them. Even if a hacker manages to steal
your Passcards from your computer, he will then have to crack the AES, RC6 or BlowFish encryption used in your Passcards
and Identities, and they are nearly impossible to crack.

How to Maximize Personal Data Security in RoboForm. 
If you want to achieve the maximum level of security, do this: 
* Check "Password-Protect New Passcards" in the "Options -> Security" dialog. 
* Make sure that all sensitive Passcards and Identities are password-protected. The Lock icon should be yellow and locked, and
the Protected menu item should be checked. Remember that anybody who can read files on your computer will be able to
extract your sensitive info from any Passcard or Identity that is not password-protected -- so do password-protect them. 
* When you leave your computer, click the "Logoff" button on the RoboForm toolbar so that all entered passwords are purged
from memory.

RoboForm2Go achieves greatest security due to physical storage factors. 
When you pull out portable disk (USB disk usually) with RoboForm data from a computer, 
no traces of your Passcards are left on the computer where you use RoboForm2Go. 
This is because your Passcards and other sensitive RF data is stored on the disk that you pulled out. 
Therefore you achive greatest physical security with RoboForm2Go. 
But your sacrifice is less duplication for your passcrads (only one copy on USB disk). 
RoboForm2Go disk becomes a single point of failure: if you lose it, you lose all your Passcards.

Managing User Data
Identities, Passcards and Safenotes are files stored in the User Data Folder. 
Each RoboForm Identity and Passcard is stored in a separate file.

Identity files have a RFT extension. 
Contact files have a RFC extension. 
Passcard files have a RFP extension. 
Bookmarks files have a RFB extension. 
Blocking Passcards files have a RFX extension. 
Safenote files have a RFN extension. 

http://www.roboform.com/support/faq#security
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SearchCard files have a RFQ extension. 
License and option files have RFO extension.

View User Data Folder. 
To view User Data Folder in Windows Explorer, select "RoboForm -> Profiles -> Explore Folder".

Refresh User Data Folder. 
Select RoboForm -> Profiles -> Refresh Folder to refresh RoboForm
file from the files in User Data Folder. RoboForm caches contents of User
Data Folder in memory, so if you made changes to this folder using
Windows Explorer or other file manipulation programs, you must refresh
RoboForm file cache.

Change User Data Folder. 
Select RoboForm -> Options -> User Data -> Set Folder and choose a
new User Data Folder. Once you click OK, RoboForm will start reading
Identities and Passcards from the selected folder and saving new Passcards
and Identities to the selected folder. 
When you change the User Data Folder, RoboForm does not copy RFT and
RFP files from the old folder to the new folder.

Where are RoboForm2Go user files stored on USB disk and how to
change location of this folder. 
RoboForm2Go only: RoboForm Data files (Passcards, etc) are stored in
folder "\My RoboForm Data\Default Profile" of your USB disk. To change the folder where RF Data is stored, use
"RoboForm2Go -> Options -> User Data -> Set Folder" command. Section on Portable.ini file provides more details on how
RoboForm2Go data files are searched for on USB drive when RoboForm2Go starts up.

Backup and Restore

Backing up and restoring RoboForm User Data is just copying files. You can do it yourself or RoboForm can do it for you.

Backup User Data. 
- In "RoboForm -> Options -> User Data" click "Backup" button. 
- Select a folder to which you want to backup (copy) your Passcards and Identities. 
- RoboForm will erase all files in the destination folder and then 
- RoboForm will copy your user data files to the destination folder.

Or you can use Windows Explorer to copy all files from RoboForm User Data folder to backup folder.

Restore User Data. 
In "RoboForm -> Options -> User Data" click "Restore" button. 
- Select a folder from which you want to restore (copy) your Passcards and Identities. 
- RoboForm will erase all files in current User Data folder and then 
- RoboForm will copy your RoboForm data files from restore folder to User Data folder.

Or you can use Windows Explorer to copy all files from your backup device to User Data folder.

Copy from Computer A to Computer B. 
- Backup data from Computer A to a backup device/volume such as floppy disk. 
- Insert this device/volume into Computer B. 
- Restore RoboForm files from backup device.

Or you can use Windows Explorer to copy all files directly from one computer to another.

Refresh after Restore. 
If you restore your RoboForm Passcard and Identity files by copying them to the "My RoboForm Data" folder using Windows
Explorer or any other file copy program, then you must ask RoboForm to re-read the files after the copy, because RoboForm
does not know that files have been updated. 
Select RoboForm -> Profiles -> Refresh Folder to make RoboForm re-read all user files.

Multiple RoboForm Profiles

If you share a computer with other people and you want to have several separate sets of Passcards and Identities within one
Windows user then use RoboForm Profiles for this.

Available only in RoboForm Pro.

RoboForm Profile. 
Each RoboForm Profile is an independent set of Passcards, Identities and Safenotes that has a separate Master Password.



 (http://www.roboform.com/images/CustomizeMenu-6.png)
Options -> IE Menus

Current Profile. 
Current Profile is the RoboForm Profile that is currently seen in RoboForm. Initially RoboForm creates a Profile for you that
has is named "Default Profile".

New Profile. 
Select "RoboForm -> Profiles -> New" to create new RoboForm Profile. Newly created Profile becomes current. New Profile
initially has no Passcards or Identities and it has no Master Password.

Switch Profile. 
Select "RoboForm -> Profiles -> <ProfileName>" to switch from one Profile to another. Remember that each RoboForm
Profile has a separate Master Password.

Rename Current Profile. 
Select "RoboForm -> Profiles -> Rename" to rename the current Profile.

Delete Current Profile. 
Select "RoboForm -> Profiles -> Delete" to delete the current Profile. The Profile that follows the deleted Profile will become
current.

Technical Details. 
RoboForm Profile is just a folder (or tree of folders) with RoboForm Passcards, Identities, Safenotes and Master Password in it.
So list of RoboForm Profiles is computed as all folders that are: (i) siblings of the current RoboForm Profile folder, and (ii)
contain Passcards, Identities, or Safenotes files.

Multiple Windows Users

Applies only to installed RoboForm, not to RoboForm2Go.

Separate Windows users maintain separate sets of RoboForm User Data and Settings: 
* Each Windows user has its own RoboForm Profile, so Identities, Passcards, Safenotes and Master Password. 
* Each Windows user has its own set of RoboForm settings (options that you see in "RoboForm -> Options").

Installing RoboForm. 
When you install RoboForm, it installs only for the current Windows user. However if you check "Install RoboForm for All
Windows Users" checkbox in the installer, RoboForm installs for all Windows users.

Limited and Administrator Users. 
If a Windows user is Limited (that is, not Administrator) and Administrator user did not previously install RoboForm then
Limited User will not have RoboForm controls that can be installed only by Administrator: 
- RoboForm buttons in Standard IE toolbar, 
- RoboForm context menu items in IE and IE-based browsers.

If you want Limited User to use all RoboForm controls, you must first install RoboForm from Administrator user and then
install it from the Limited User.

Reference
RoboForm Commands

Applies only to installed RoboForm, not to RoboForm2Go.

This is a complete list of RoboForm commands that are available in RoboForm IE Context Menu and through RoboForm
button is IE Standard Toolbar.

http://www.roboform.com/images/CustomizeMenu-6.png


Initially RoboForm commands marked with "*" in the table are not visible but you can make them visible by selecting
Customize Menu from IE context menu.

Most commands can also be invoked with keyboard shortcuts. You should hold the ALT key while pressing the shortcut key on
keyboard, this would cause execution of the command.

Keyboard shortcuts are shown in "RoboForm -> Options -> Keyboard", where each shortcut can be enabled or disabled.

List of commands:

Command Key Toolbar AutoFill dialog Editors
Save Forms [ Save - Passcard -> New...
Fill from My Identity 1-9 Click Identity Fill Forms Action -> Fill Forms
Fill from Matching Passcard M Passcards -> select Passcard Fill Forms Action -> Fill Forms
Fill Forms ] Fill Forms Fill Forms -
Fill w/o Asking Fill Forms -> Fill without Asking Fill Forms -
Fill & Submit Z Fill Forms -> Fill & Submit Fill & Submit -
Login X Select Passcard - Login
GoFill X select -> right-click -> GoFill - GoFill
GoTo X select -> right-click -> GoTo - GoTo
Set Fields = Fields -> Set Fields - -
Reset Fields - Fields -> Reset Fields - -
Clear Fields 0 Fields -> Clear Fields - -
Identities Editor , Identities -> Edit ... -> Edit select Identity
Passcards Editor . Logins -> Edit ... -> Edit select Passcard
Safenotes Editor / Safenotes -> Edit - select Safenote
Rename select -> right-click -> Rename ... -> Rename Passcard -> Rename
Clone select -> right-click -> Clone ... -> Clone Passcard -> Clone
Delete select -> right-click -> Delete ... -> Delete Passcard -> Delete

Delete key Delete key
Logoff L Logoff - Logoff
Options O RoboForm -> Options - View -> Options
Customize Menu right-click page -> Customize - View -> Options -> CtxMenu
Password Generator P mouse over Generate - Tools -> Password Genr
RoboForm Toolbar R RoboForm -> Hide - -
Taskbar Icon I RoboForm -> Tools -> Taskbar Icon - Tools -> Taskbar Icon

Command Line Options

Command Command Line
Login Passcards.exe -l PasscardPath
GoFill Passcards.exe -g PasscardPath
GoTo Passcards.exe -t PasscardPath
PasscardPath must be complete file path enclosed in " " if it has spaces. Example of correct command line for login:

      Passcards.exe -l "C:\My RoboForm Data\Dave\Bank of AM.rfp"
    

Passcard File Format

If you want to generate Passcards in a program, you need to know what format of Passcard file is. Passcard file (*.RFP) has
several different formats depending on level of encryption and version of RoboForm. Here we disclose only the original plain-
text format of Passcards that dates back to ver 4.6.x. Current versions of RoboForm can read this format but they do not write
it.

Passcard in this format is a text file in UNICODE, so you can read it with MS Notepad or Word. First line contains Passcard
URLs in this format:

      URL3:ver1:MatchURL\1GotoURL
    

GotoURL and MatchURL are the actual URLs. \1 is binary byte 1.

URL line is followed by list of fields, each field taking 3 lines:
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      field-name
      0
      field-value
    

The sequence of fields is finished with empty line that designates end of fields.

Custom Fields in Identity
If you need to robo-fill a field that is not listed in the Identity Editor then you can define your own Custom Field. Most of
Custom Field's functionality is only available in RoboForm Pro. In the free version number of custom fields is limited to 3.

Custom fields are defined by you in the Custom tab of the Identity Editor (the rightmost tab). For each custom field you need
to specify (from left to right):

Field Name.
It identifies the field. It is also used as the Main Match String for the field.

Field Value.
Determines what RoboForm puts into an online form field.

Other Match Strings.
A list of text captions that are used to match this field in
an online form. 
Every Match String occupies exactly one line. If you need
to have more than one Other Match String, press ENTER
after you finished entering the previous Other Match
String.

Match Rules. 
Field Name and Other Match Strings together constitute Match
String List of the custom field. The Match String List is used to
recognize online form field by comparing its text caption with all
Match Strings contained in the Match String List. Specifically,
every Match String from Match String List is matched against the
text caption of an online field. If a match is found, the Identity
field that matched is used to fill the online field.

Example: You want RoboForm to fill "Message" field with "My Great Speech". This field may also have captions "Your
Comments" and "Say It Here". 
In the Custom tab you find an unused single-line field and you enter into it: 
* Field Name: enter "Message", 
* Field Value: enter "My Great Speech", 
* Other Match Strings: enter "Comments", press ENTER, enter "Say It Here". 
Check how it works in the Custom Fields Test Form (http://www.roboform.com/support/filling-test/custom-fields).

Words and Punctuation. 
RoboForm matches case-insensitive word sequences. All punctuation characters (, . - ! ?) are removed from both Match Strings
and online field text captions before matching. Select "Identity -> Save" or click Save (diskette) button on Editor toolbar after
entering Match Strings into the Identity Editor and it will show how Match Strings will look after punctuation has been
removed.

Example: You need to add a custom field for a checkbox captioned "Are you 18! or over?". 
In the Custom tab you find an unused single-line field and enter into it: 
* Field Name: enter "Old Enough" (will work as a match too), 
* Field Value: enter "X", 
* Other Match Strings: enter "Are you 18! or over?" and click Save. It will turn into "are you 18 or over" which will be used for
matching. 
Check how it works in the Custom Fields Test Form (http://www.roboform.com/support/filling-test/custom-fields).

Multiline Custom Fields. (Pro Version Only) 
One field at the bottom of the Custom Tab is a multi-line field. It has more than one line in its Field Value. This field will
increase its size as you add more lines to it. A lso if you fill unused multiline fields at the bottom of the Custom tab, another
empty multiline field will be added when you click Save or reopen the Identity Editor. So the number of multiline fields is
unlimited.

Example: You want RoboForm to fill in a resume for you at an online job search site. Add a custom multiline field named
"Resume" (this will match any caption with word resume in it) and assign it a multiline value "John Smith <ENTER>VirtuCon
1997-99<ENTER>Chief Designer". 

http://www.roboform.com/support/filling-test/custom-fields
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Check how it works in the Custom Fields Test Form (http://www.roboform.com/support/filling-test/custom-fields).

Check-Box Fields. 
RoboForm can robo-fill checkbox fields (RoboForm has no standard checkbox fields, so you need to create a custom field).
The Match Strings of this field will be matched against the text caption of the online checkbox field. Use any "*" value to cause
checking of the checkbox field, use "0" value (starting with RF ver 6.9.4) to cause unchecking of the checkbox. Empty value ""
tells RoboForm to ignore the checkbox (no checking or unchecking). 
Example: Add custom field named "18 or over" and assign it an "*" value. It will check any check box that has "18 or over" in
its caption. See how it works in the Custom Fields Test Form (http://www.roboform.com/support/filling-test/custom-fields).

Radio Button Fields. 
RoboForm can robo-fill custom radio button fields (Credit Card Type is an example of a standard radio button field). To make
this happen, create a custom field. RoboForm breaks an online radio button field into a field caption and list of field values.
The caption of the online field is matched against the Match Strings of your custom field, and the value list of the online radio
button field is matched against the value of your custom field. 
Example: Add custom field named "Marital Status". Assign it any of these values: "Married", "Single", "Divorced", "Widow". See
how it works in the Custom Fields Test Form (http://www.roboform.com/support/filling-test/custom-fields).

Subset Matches and Exact Matches. 
The Match String of the custom field matches a sequence of words in the online field caption, so that the matched word
sequence must be a subset of the entire online field caption. Words in the sequence must be exactly the same and their order
must be exactly the same. The case of words (lower, upper or capitalized) is disregarded, though.

Sometimes you want to specify Match Strings that match the entire field caption but not its subsets. Use "=Match String" for
this. 
Example: If you specify "=Comments" as Other Match String for the Message field, then it will match only fields that have the
"Comments" caption but not the field with "Your Comments" or "Comments Here" captions.

HTML Field Name Matches. 
We do not believe in using HTML Field Names in matching, because often these names do not make much sense and can even
be misleading. But if your field has no text caption at all (for example: it only has a picture caption), then HTML field names
are used for matching. So if no match is found using regular text captions, RoboForm tries to match a field by its HTML name.
All custom field Match Strings are used in this last-resort match attempt and spaces between words are disregarded in HTML
field ID match. 
Example: Add custom field named "Attitude", its value being "Positive". The field that has picture as a caption and "attitude" as
its HTML name will match in the Custom Fields Test Form (http://www.roboform.com/support/filling-test/custom-fields).

http://www.roboform.com/support/filling-test/custom-fields
http://www.roboform.com/support/filling-test/custom-fields
http://www.roboform.com/support/filling-test/custom-fields
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